EngageWhiz supports the following browsers:


What browser versions are supported?

  • iOS/Safari 10.3.3+
  • Microsoft Edge 44+
  • Google Chrome 50+
  • Mozilla Firefox 53+

What browsers aren't suported?

  • All versions of Internet Explorer.

Notes

Some browsers do not support all APIs/web standards equally. iOS Safari does not support service workers or push notifications. The live transcription feature relies on an API currently only supported in Google Chrome and Firefox. If using Safari, Safari 11+ is highly recommended.